summaryrefslogtreecommitdiffstats
path: root/manifests/weblate/python_modules.pp
blob: 660bab8ac87d4fae1d20ffc0824e42063469ac58 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
# Manage Weblate dependencies that are in not in Debian
class tails::weblate::python_modules () {

  $pip_packages = [
    'python3-pip',
    'python3-setuptools',
  ]

  ensure_packages($pip_packages)

  # The following deps are in Debian Stretch but with a version that is older
  # than needed by Weblate 3.0. The versions noted as comments are the
  # requirements for the current Weblate version we are running (check
  # manifests/weblate.pp to know which version it is).

  tails::pip_package_from_repo { 'celery':
    version => '4.3.0',  # >= 4.0
    tag => 'v4.3.0',
    url     => 'https://github.com/celery/celery',
  }

  tails::pip_package_from_repo { 'celery-batches':
    version => '0.2',  # >= 0.2
    tag => 'v0.2',
    url     => 'https://github.com/percipient/celery-batches',
  }

  tails::pip_package_from_repo { 'django':
    version => '1.11.27',  # >= 1.11
    url     => 'https://github.com/django/django',
  }

  tails::pip_package_from_repo { 'django-appconf':
    version => '1.0.2',  # >= 1.0
    tag => 'v1.0.2',
    url     => 'https://github.com/django-compressor/django-appconf',
  }

  tails::pip_package_from_repo { 'django-compressor':
    version => '2.2',  # >= 2.1.1
    url     => 'https://github.com/django-compressor/django-compressor',
    require => Exec['pip_install_django-appconf']
  }

  tails::pip_package_from_repo { 'djangorestframework':
    version => '3.8.2',  # >= 3.8
    url     => 'https://github.com/encode/django-rest-framework',
  }

  tails::pip_package_from_repo { 'filelock':
    version => '3.0.4',  # >= 3.0.1
    tag => 'v3.0.4',
    url     => 'https://github.com/benediktschmitt/py-filelock',
  }

  tails::pip_package_from_repo { 'jellyfish':
    version => '0.7.2',  # >= 0.6.1
    tag => '0.7.2',
    url     => 'https://github.com/jamesturk/jellyfish',
  }

  tails::pip_package_from_repo { 'translate-toolkit':
    version => '2.3.1',  # >= 2.3.1
    url     => 'https://github.com/translate/translate',
  }

  # The following deps are in Debian Buster, but not in Stretch.

  tails::pip_package_from_repo { 'django-crispy-forms':
    version => '1.7.2',  # >= 1.7.2
    url     => 'https://github.com/django-crispy-forms/django-crispy-forms',
  }

  tails::pip_package_from_repo { 'oauthlib':
    version => '3.1.0',  # >= 3.0.0
    tag     => 'v3.1.0',
    url     => 'https://github.com/oauthlib/oauthlib',
  }

  tails::pip_package_from_repo { 'openpyxl':
    version   => '2.6.0',  # >= 2.5.0
    url       => 'https://bitbucket.org/openpyxl/openpyxl/src/default',
    repo_type => 'hg',
  }

  tails::pip_package_from_repo { 'phply':
    version => '1.2.4',
    url     => 'https://github.com/viraptor/phply',
  }

  tails::pip_package_from_repo { 'redis':
    version   => '3.3.11',  # >= 3.3.11 -- from celery's kombu
    url       => 'https://github.com/andymccurdy/redis-py',
  }

  tails::pip_package_from_repo { 'ruamel.yaml':
    version   => '0.16.5',
    url       => 'https://bitbucket.org/ruamel/yaml/src/default',
    repo_type => 'hg',
  }

  tails::pip_package_from_repo { 'siphashc':
    version => '1.0',  # >= 0.8
    tag => 'v1.0',
    url     => 'https://github.com/WeblateOrg/siphashc',
  }

  tails::pip_package_from_repo { 'social-auth-core':
    version => '3.1.0',  # >= 3.1.0
    url     => 'https://github.com/python-social-auth/social-core',
  }

  tails::pip_package_from_repo { 'social-auth-app-django':
    version => '3.1.0',  # >= 3.1.0
    url     => 'https://github.com/python-social-auth/social-app-django',
  }

  tails::pip_package_from_repo { 'translation-finder':
    version => '1.7',  # >= 1.0
    url     => 'https://github.com/WeblateOrg/translation-finder.git',
  }

  tails::pip_package_from_repo { 'user-agents':
    version => '1.1.0',  # >= 1.1.0
    tag => 'v1.1.0',
    url     => 'https://github.com/selwin/python-user-agents',
  }

}